domingo, 23 de diciembre de 2012

¿Cómo instalo el controlador para la ATI/AMD Radeon 4200 en Ubuntu 12.10 Quantal?


¡Trabajadores!


El peronismo no se originó de un repollo. Partió de la auténtica necesidad del Pueblo por lograr un bienestar. Ahora, esa necesidad era real, no era un invento de 4 vivos para hacerse con el poder.

En el caso de las actualizaciones doctrinarias y de versiones con Ubuntu sucede más o menos lo mismo.

No fueron pocos los usuarios que - deseando actualizar su Ubuntu 12.04 a 12.10 - encontraron un problema concerniente con sus adaptadores gráficos. El problema al que nos referimos aparece únicamente a los usuarios de los adaptadores de vídeo ATI/AMD Radeon, y específicamente a ellos que tienen una AMD Radeon de la serie HD4000, HD3000 o HD2000. En mi Notebook Acer Aspire 5542 puedo reproducir el problema, pues está munida de un excelente ATI/AMD Radeon 4200 integrado. En consecuencia, me propuse estudiar el problema, tomándolo en mis manos con el fin de lograr una solución para el Pueblo Argentino.

La raíz de este inconveniente de video subyace, como no podía ser de otra forma, en la política. Recientemente la fabricante AMD dio a informar el abandono del soporte a dichos modelos. Como resultado, luego de actualilzar a Ubuntu 12.10 Quantal, la versión empaquetada y entregada con este Ubuntu del controlador para Radeon (el FGLRX), ya no será funcional, dejando en el desamparo a quien por tantos años ha luchado.

De hecho, este problema no se relaciona en un 100% con Ubuntu 12.10, sino que mas bien viene causado por la versión 1.13 (septiembre 2012) del servidor de terminal gráfica XOrg, incluido en Ubuntu 12.10 Quantal y en las más modernas distribuciones de GNU con Linux.
Cuando los Pueblos han clamado Justicia, a ellos ha asistido - y con todas sus herramientas - el Justicialismo. No en vano hemos lanzado una máxima, aquella que reza "combatir al Capital". De manera que como Conductor de los Argentinos, he dado con la solución que el mundo anhelaba para su bienestar y tranquilidad bajo Ubuntu Quantal.

Como primera medida, han de saber que si cuentan un adaptador encuadrado en los siguientes:
  • AMD Radeon HD 4000 Series
  • AMD Radeon HD 3000 Series
  • AMD Radeon HD 2000 Series
  • AMD Radeon HD Series AGP
  • AMD Mobility Radeon HD 4000 Series
  • AMD Mobility Radeon HD 3000 Series
  • AMD Mobility Radeon HD 2000 Series

...deberán utilizar el controlador "Legacy" (legado, antiguo) de AMD Radeon, que actualmente es la versión Catalyst 12.6 Legacy

En apretado resumen técnico:
  • Ubuntu 12.04LTS Precise + XOrg 1.12 + driver fglrx = OK
  • Ubuntu 12.10 Quantal + XOrg 1.13 + driver fglrx = FALLA (incluso si intentamos retroceder a XOrg 1.12, ya que Uniy dejará de funcionar)
Solución: Ubuntu 12.10 + XOrg 1.13 + fglrx legacy 12.6

Tal como se expone, con el fin de hacer realidad efectiva esta solución, hemos de instalar Ubuntu 12.10 desde cero, y antes que realizar cualquier actualización general, proceder a instalar la versión Legacy 12.6 del controlador fglrx.

Afortunadamente, para obtener esta versión de flglrx, podemos seguir tres métodos diferentes.

a) Descarga de web oficial e instalación típica (Método Tradicional)
Consiste en descargar el archivo en cuestión desde la Web Oficial de AMD haciendo Click Aquí, para luego ejecutar el script de instalación.

En la web oficial, procederemos a la descarga completando el formulario propuesto:

Para ejeccutar el script de instalación abrimos una terminal con Ctrl+Alt+T e ingresamos el siguiente Comando de Organización.
sudo sh ./amd-driver-installer-12.6-legacy-x86.x86_64.run

Luego, seguiremos las clásicas pantallas de instrucciones.

b) Empaquetado del controlador en un archivo DEB instalable:
Como alternativa a ejecutar el guión, podremos construir el controlador empaquetado, con los siguientes comandos:

wget http://www2.ati.com/drivers/legacy/amd-driver-installer-12.6-legacy-x86.x86_64.zip
unzip amd-driver-installer-*
sudo sh ./amd-driver-installer-*.run --buildpkg Ubuntu/quantal
sudo dpkg -i fglrx*.deb
sudo aticonfig --initial -f

c) Usar una PPA para descargar un empaquetado ya hecho.
Como tercer método, podremos utilizar un repositorio ya empaquetado, creado por el compañero peronista Tomasz Makarewicz para este único propósito, con lo cual nos evitaríamos cualquier problema de empaquetado que pudiese resultar.
 
sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy
Si con este método algo no funciona, siempre podremos remover el repositorio y volver atrás, corriendo:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:makson96/fglrx
 

En cualquiera de las instancias, debemos realizar los pasos indicados y luego reiniciar nuestro equipo para que se comience a utilizar el controlador Legacy compatible con nuestra confiable y peronista Radeon HD serie 4xxx, 3xxxx o 2xxxx.

40 comentarios:

  1. Yo probé el tercer método en mi Linux Mint 14 (que toma como base a Ubuntu 12.10) y funcionó estupendamente. Lo comenté también en mi blog sobre infografía con software libre http://infografia-libre.blogspot.com.es/2012/12/como-instalar-el-driver-privativo-amd.html

    Los otros dos no los había probado, los comentaré en esa misma entrada y enlazaré a tu blog.

    Un saludo desde España. ;)

    ResponderEliminar
    Respuestas
    1. Estimado As de picas:

      Un pueblo Libre es un pueblo Feliz, y lo será siempre que camine bajo las banderas de la Soberanía y la Justicia Social:

      Como el software libre es la versión 2.0 de la justicia social, y su blog nos ha gustado, obraremos de manera recíproca incluyéndolo en nuestra sección "La Comunidad Organizada 3.0", donde encontrará otros blogs dignos de mención y estudio, y que hablan nuestro mismo idioma: el de la Liberación.

      Atte.

      Juan Perón

      Eliminar
  2. Utilice el 1mer y 3cer metodo y funcionan bien cool

    ResponderEliminar
    Respuestas
    1. Estimado Anónimo:

      Ahora tendrá video acelerado gracias al Justicialismo.

      Atte.

      Juan Perón

      Eliminar
  3. el tercer metodo no me funciona en una ati radeon 4200, no me reinicia (la pantalla se pone en negro y de ahi no pasa, por lo cual tengo que formatear)

    ResponderEliminar
    Respuestas
    1. Estimado Ed:

      No necesitas formatear para restaurar al estado anterior. Simplemente inicia Ubuntu a través de la consola (presionando F4 o Esc durante el inicio se abrirá el menú de Grub), loguéate a la consola de texto con su usuario y contraseña de administración, e ingresa:

      sudo apt-get install ppa-purge
      sudo ppa-purge ppa:makson96/fglrx

      Luego reinicia en modo de video seguro y prueba con los otros métodos, sobre todo el segundo.

      Atte.

      Juan Perón

      Eliminar
  4. El primer metodo me funcionó pero no me dejo cambiar la resolución de pantalla 800x600 y me encondio el menu

    El ultimo tambien funcionó, pero al minimizar una ventana la animacion se ve lenta y al apagar el equipo aveces se congela

    tengo una ATI RADEON MOBILITY HD 3200 mi notebook es un compaq 515... me podría ayudar soy nuevo en Ubuntu

    ResponderEliminar
    Respuestas
    1. Estimado Anónimo,

      Todos hemos dado nuestros primeros pasos temerosos, pero por medio de práctica, estudio y porrazos, hemos podido caminar, luego andar en bicicleta, y finalmente caminar sobre la luna.

      Ubuntu es un sistema que requerirá cierto estudio, pero te ofrecerá lo que ningún otro sistema esclavo del Capital tiene: la Libertad. La misma no se obtiene ni se regala, es necesario luchar y ¡ay! a veces morir por ella.

      En este caso particular, el método más efectivo sin duda es el segundo, donde tu mismo creas el paquete de instalación y lo instalas. Los métodos 1 y 3 simplemente intentan instalar paquetes generados por un tercero, el el primer caso el fabricante, y en el segundo caso, un compañero de origen alemán que empaqueta el controlador. Sin embargo, ellos podrían tener algunas diferencias mínimas de arquitectura con tu equipo (por ej. usar la ATI 4200 en lugar de la 3200, y que ello provoque alguna falla de compatibilidad).

      Por lo que nos comentas, puede que no hayas instalado realmente el controlador AMD Catalyst, pues cuando sólo puedes usar el modo gráfico de 800x600 y se ve lento, singnifica que Ubuntu ha arrancado con el controlador VESA, que es un estándar antiguo de baja tecnología pero aceptado por todas las placas de video comunes. Es bueno para tener una gráfica funcional cuando existen problemas, pero estamos de acuerdo en que no es lo mejor.

      Por favor si has usaado los métodos 1 y 3, asegúrate de desinstalar los mismos. Podrás hacerlo abriendo una consola con ctrl+alt+T e ingresando los siguientes comandos de Organización:

      sudo apt-get purge fglrx*

      sudo apt-get install ppa-purge

      sudo ppa-purge ppa:makson96/fglrx

      Una vez desinstalado todo, emprende el segundo método, con los comandos:

      Para bajar el controlador, copia y pega en la consola lo siguiente, y dale enter:
      wget http://www2.ati.com/drivers/legacy/amd-driver-installer-12.6-legacy-x86.x86_64.zip

      Luego descomprímelo con:
      unzip amd-driver-installer-*

      A continuación ejecuta el instalador con permisos de superusuario ("sudo") y oblígalo a que haga un paquete. El manual del controlador lo explica, es con:

      sudo sh ./amd-driver-installer-*.run --buildpkg Ubuntu/quantal

      Y luego instalas el paquete resultante:
      sudo dpkg -i fglrx*.deb

      Finalemente lo configuras:
      sudo aticonfig --initial -f

      Y reincias tu equipo con
      sudo reboot

      Con esto, debería funcionar!

      Te deseamos la mayor de las suertes con tu Ubuntu.

      Atte.

      Juan Perón

      Eliminar
    2. Gracias por resonder pero al instalar el controlador con
      sudo sh ./amd-driver-installer-*.run --buildpkg Ubuntu/quantal

      me sale esto y no puedo seguir, lo subi a pastebin es muy largo el texto:
      http://pastebin.com/Fg5ENcXD

      Eliminar
    3. Estimado Anónimo:

      Gracias por acercarnos lo que te devuelve el sistema, pues facilita la instalación.

      Se trata de un informe que avala el proceso de creación del paquete, y parece que no tienes problemas a excepción de la existencia del paquete dpkg-dev, que se encarga del desarrollo de paquetes en Ubuntu. Te informa que lo instales y pruebes nuevamente.

      Para instalar dpkg-dev desde la terminal, simplemente ingresa:

      sudo apt-get install dpkg-dev

      Y luego continúa con los pasos propuestos, debería compilar el paquete e instalarlo.

      Atte.

      Juan Perón

      Eliminar
    4. acabo de instalar dpkg-dev
      ahora me da otro problema creo...
      http://pastebin.com/dX62bc73

      Eliminar
    5. Estimado Anónimo:

      Aparentemente el motivo es el mismo, en este caso te pide las librerías debhelper, dh-modaliases, y execstack, lo cual lo informa a lineas 54 del pastebin que nos has acercado.

      Esto es así porque aparentemente nunca has compilado nada. Puedes instalar todo un "combo" de herramientas esenciales básicas para compilar ingresando:

      sudo apt-get install build-essential

      Estas no ocupan mucho espacio, y forman algo así como una caja de herramientas báisca para estos menesteres. Luego de instalar esta, comienza instala las herramientas específicas que te ha pedido el compilador:

      sudo apt-get install debhelper
      sudo apt-get install dh-modaliases
      sudo apt-get install execstack

      Prueba nuevamente, si vuelve a pedir más paquetes faltantes, intenta instalarlas con el la orden sudo apt-get install nombredelpaquete

      Atte.

      Juan Perón

      Eliminar
    6. se logro instalar... pero al poner sudo dpkg -i fglrx*.deb
      me sale esto parece un bug o algo http://pastebin.com/065EyX9n

      Error! Bad return status for module build on kernel: 3.5.0-17-generic (i686)
      Consult /var/lib/dkms/fglrx/8.970/build/make.log for more information.

      en el archivo make.log me sale esto http://pastebin.com/SVa4XcBB

      Eliminar
    7. Estimado Matías:

      Felicitaciones!

      Has tenido éxito en compilar tu primer controlador y empaquetarlo en un archivo DEB. Realmente ha sido un logro bastante complejo, pero ten en cuenta que acabas de compilar un controlador de video completo de última generación.

      Evidentemente según el pastebin que nos envías, surgió el que proceso de compilación tuvo ciertas adevertencias en cuanto a la compilación (tal vez porque el código fuente del controlador es anterior al kernel versión 3.5.0.17-generic).

      Este tipo de percances o advertencias suelen ser cosa corriente durante las compilaciones complejas como estas, y en este caso podrás pasar de ella. La informática y la programación tiene ciertos resquicios, pero aún así los hombres y mujeres al servicio de un ideal pulen Linux día a día los códigos para que sea compatible con la mayor cantidad de plataformas y equipos posibles.

      En tu caso y por lo que nos envías, Ubuntu instaló el módulo por tí compilado, en el kernel de tu sistema i686, y aparentemente lo está ejecutando de manera exitosa. En caso de que no fuese así, lo reportaría con mensajes de error pertinentes y no reemplazaría los módulos anteiores.

      Te recomendamos evaluar el funcionamiento del controlador de video, simplemente usando tu equipo. Ten en cuenta que si actualizas el kernel de tu sistema operativo, en ciertos casos podria ser necesario que repitas nuevamente la instalación del paquete ya compilado (no hace falta que lo compiles, ya hiciste ese trabajo).

      Por ello, te sugerimos que guardes en tu carpeta de usuario el paquete fglrx-dev_8.970-0ubuntu1_i386.deb que acabas de compilar.

      Si actualizas el kernel, simplemente deberías ir a la carpeta donde tienes el archivo fglrx-dev_8.970-0ubuntu1_i386.deb, y reinstalarlo.

      Y si por algún motivo en tu sistema no tuviese gráfica como para hacerlo de manera sencilla, siempre podrás reinstalar el paquete desde la terminal ingresando:

      sudo dpkg -i fglrx*.deb

      Atte.

      Juan Perón

      Eliminar
    8. Lo malo es que se instalo el controlador VESA nuevamente... no me rendiré aún gracias por toda la ayuda.

      Eliminar
    9. Yo iba con un Vesa, la verdad funciona bien, pero el ventilador de la gráfica va como loco, no consigo configurar una 5870m actualmente...estoy probando si con el ultimo codigo que pusiste funciona...Muchas gracias

      Eliminar
  5. Oye, excelente post, pero me gustaria saber si lo volveras a hacer para ubuntu 13.04?.

    ResponderEliminar
    Respuestas
    1. Estimado Ed:

      El Justicialismo se ha esforzado en proveer siempre las soluciones a los problemas del Pueblo.

      Lamentablemente no creemos que en este caso podamos volverlo a hacer, al menos de forma oficial. AMD/ATI ha dejado de prestar soporte para este chip Radeon 4200 de cuatro años atrás, y ha implementado nuevos controladores para las series más nuevas que no sirven con el mismo.

      Esto es un problema, pues como se detalla en este nuevo artículo, 12.10 Quantal será mediante este truco, la última distro de Ubuntu que soporte oficialmente video acelerado con este chipset.

      Nominalmente, se debe a un problema conflictual entre el controlador ATI Catalyst nuevo, las versiones nuevas de XOrg (el servidor de video gráfico), y el chip gráfico ATI 3200/4200, el cual aparenta ser de difícil solución, por lo que AMD suspende el servicio y declara "legacy" u obsoleto al chip para dicha arquitectura, aduciendo que dirigirán su esfuerzo a las plataformas gráficas más modernas, excitantes, y toda esa perorata típica del Capitalismo.

      Tal vez exista más adelante algún truco no oficial para hacer funcionar la vieja pero aún funcional Radeon 4200 con las versiones más nuevas de Ubuntu, y si ello es así lo publicaremos. Pero oficialmente, parece que no habrá nada mas. Esta es la manera en la cual el fabricane plantea la obsolescencia controlada de su hardware, y nos sume en un consumismo sin Patria ni Bandera.

      Pero es fácil aplicando la opción del Justicialismo. De momento contamos con equipo munido de video AMD/ATI Radeon 4200 que nos da excelentes resultados, y que está munido del antiguo pero funcional Ubuntu 10.10, de modo que opera excelentemente en ese sistema veterano. Si no desea algo tan antiguo, y aún busca aceleración oficial de video, le recomendamos quedarse con la LTS actual (Ubuntu 12.04LTS Precise Pangolin). Con la misma y el controlador de video indicado, tendrá excelente desempeño hasta el final de ciclo de actualizaciones, mientras escapa a la negra mano de AMD.

      Atte.

      Juan Perón

      Eliminar
  6. Oye, entonces el nuevo driver catalyst 13.1 soluciona este problema?
    Por ahi lei que soportaba xorg 1.13.

    ResponderEliminar
    Respuestas
    1. Estimado ed:

      Podría ser. Sin embargo, el problema no reside tanto en que soporte xorg 1.13, sino en que no se soporta la ATI 4200 que se indica en este artículo.

      Atte.

      Juan Perón.

      Eliminar
  7. revise en la pagina de drivers de amd y el nuevo controlador soporta hasta xorg 1.12. Que mal

    ResponderEliminar
  8. Hola, primero que todo felicitarte por tu blog y tú entusiasmo en ayudar, ahora, estoy usando el segundo método ya que el primero y el tercero me dejaron la pantalla en negro u.u y me sale lo siguiente cuando pongo el comando para crear el archivo .deb. ¿será porque uso linux mint 14?....Saludos

    Created directory fglrx-install.NULGIM
    Verifying archive integrity... All good.
    Uncompressing AMD Catalyst(TM) Proprietary Driver-8.97.100.3....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
    =====================================================================
    AMD Catalyst(TM) Proprietary Driver Installer/Packager
    =====================================================================
    Generating package: Ubuntu/quantal
    Error: Distro Version entered incorrectly or not supported, use --listpkg to identify valid distro versions
    Error: Distro Version entered incorrectly or not supported, use --listpkg to identify valid distro versions
    Removing temporary directory: fglrx-install.NULGIM

    ResponderEliminar
    Respuestas
    1. Estimado Gnuniko:

      Parecería ser ese el problema. Sin embargo nos resulta extraño, pues en Ubuntu Quantal funciona sin más problema. Recuerda que si tienes una ATI más moderna que la 4200, podrás decargar controladores más recientes que el FLGRX 12.6. En cambio, si tienes ATI 4200 o similar, deberás atenerte a esta consecuencia.

      Si es posible, podrás utilizar el método 3, el cual ya te provee un empaquetado, para ver si funciona.

      Atte.

      Juan Perón

      Eliminar
  9. Mi estimado Juan D. Perón:
    Tengo una Compaq Presario CQ40-630LA con 3GB de RAM, ATI Radeon HD 3200 y AMD Sempron SI-42.
    Mi situación es la siguiente; al haber actualizado desde la versión 10.04, comencé a tener graves errores en el rendimiento de mi gráfica, a penas reinicié mi PC y me quedé con la pantalla en negro. Por suerte tenía guardado el driver propietario 12.6 que me dio un excelente rendimiento... hasta ahora.
    Antes de la actualización, podía reproducir videos 1080p casi sin problemas con el driver FGLRX 12.6 Legacy. Ahora no puedo, no noto casi ninguna mejoría entre el driver 12.6 y el 13.1 (el que actualmente tengo instalado), incluso se me cuelgan un poco los videos viendo en 480p.
    Con los juegos como Need For Speed Carbono no tengo problemas, me funciona mucho mejor que con Güindous, de hecho, lo juego con gráficos al máximo.
    Lo que me parece raro es que, a pesar de tener un muy buen rendimiento con los juegos, no puedo reproducir un video sin que se me cuelgue un poco. Con XFCE y con Metacity logré una ligera mejoría, pero aún así, no logro reproducir bien los videos.
    No sé si esta información que le voy a dar, señor Perón, le servirá. Por las dudas se la doy, soy nuevo con Ubuntu:

    X.Org X Server 1.11.3
    Release Date: 2011-12-16
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 2.6.42-34-generic x86_64 Ubuntu
    Current Operating System: Linux octavio-laptop 3.2.0-38-generic #61-Ubuntu SMP Tue Feb 19 12:18:21 UTC 2013 x86_64
    Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-38-generic root=UUID=d5734c0c-0cbf-4ee4-b22c-dbfcee55bf15 ro quiet splash pciehp.pciehp_force=1 vt.handoff=7
    Build Date: 17 January 2013 06:14:10AM
    xorg-server 2:1.11.4-0ubuntu10.11 (For technical support please see http://www.ubuntu.com/support)
    Current version of pixman: 0.24.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    octavio@octavio-laptop:~$ sudo dpkg -l | grep linux-image
    [sudo] password for octavio:
    rc linux-image-2.6.32-21-generic 2.6.32-21.32 Linux kernel image for version 2.6.32 on x86/x86_64
    rc linux-image-2.6.32-44-generic 2.6.32-44.98 Linux kernel image for version 2.6.32 on x86/x86_64
    ii linux-image-2.6.32-45-generic 2.6.32-45.101 Linux kernel image for version 2.6.32 on x86/x86_64
    ii linux-image-3.2.0-35-generic 3.2.0-35.55 Linux kernel image for version 3.2.0 on 64 bit x86 SMP
    ii linux-image-3.2.0-36-generic 3.2.0-36.57 Linux kernel image for version 3.2.0 on 64 bit x86 SMP
    ii linux-image-3.2.0-37-generic 3.2.0-37.58 Linux kernel image for version 3.2.0 on 64 bit x86 SMP
    ii linux-image-3.2.0-38-generic 3.2.0-38.61 Linux kernel image for version 3.2.0 on 64 bit x86 SMP
    ii linux-image-generic 3.2.0.38.46 Generic Linux kernel image

    Espero que pueda ayudarme, y quiero aclarar también que antes de instalar el driver 13.1, he eliminado el 12.6 para no sobrescribirlo.
    Muchas gracias, atte. Octavio.

    ResponderEliminar
    Respuestas
    1. Estimado Octavio: En vista de lo que comenta, le reiteramos lo del artículo: ATI/AMD ha cesado de prestar soporte para la vieja tecnología 3200/4200 en sus controladores nuevos.
      Por tal motivo, deberá atenerse a las versiones soportadas (Lucid, Maverick, o Precise, y Quantal siguiendo las normativas aquí expuestas.

      En nuestro caso, con la 4200 funciona bien, pero no así con la 3200 de ATI, que tiene el problema que comenta. En tal caso, sugerimos permanecer con Ubuntu Precise o anterior.

      Atte,

      Juan Perón

      Eliminar
  10. Ahora la pregunta es:
    Llegara el momento en que el driver libre sobrepase al propietario para estas tarjetas de video?, pues la comunidad trabaja constantemente en el driver libre.
    En la pagina de Phoronix, habla de como el libre ha ahumentado su rendimiento con las ultimas versiones.

    ResponderEliminar
    Respuestas
    1. Estimado Anónimo:

      Esta es la pregunta del millón. La ventaja del controlador libre no reside tanto en el rendimiento, sino en que se puede mejorar constantemente, cosa que no sucede con el AMD Catalyst (y este ejemplo lo avala).

      En ciertas condiciones como el uso de este hardware sin soporte actualizado, a veces es mejor quedarse con versiones antiguas del sistema.

      Atte.

      Juan Perón

      Eliminar
  11. mi pc tiene ati mobility radeon hd 4250

    cual metodo debo usar(mi pc es una acer aspire 5251)

    gracias

    ResponderEliminar
    Respuestas
    1. Estimado Anónimo:

      Deberías estar bien con el primer método.

      Atte.

      Juan Perón

      Eliminar
  12. Hola como estan, tengo una duda Actualmente estoy usando Ubuntu 10.04 LTS, que como sabemos perderá soporte ahora en abril.

    Mi duda es, es posible actualizar de la versión 10.04 a la 12.04 sin perder alguna configuración? Es decir, si actualizo seguiré teniendo aceleración por hardware?

    Soy novato en esto de ubuntu y pues la verdad quisiera saber si es posible actualizar entre distintas versiones ya que no quiero dañar mi actual instalación de ubuntu.

    ResponderEliminar
    Respuestas
    1. Estimado Robin:

      Normalmente, recomendamos instalar la versión directamente a mano. La actualización debería funcionar sin problemas, pero como sabes, tal garantía no es absoluta. De hecho, muchas veces preferimos dejar versiones antiguas y funcionales a arriesgar un cambio.

      Por supuesto, puedes descargar la ISO de 12.04LTS e instalarla a través de un pendrive, a fin de evaluar si te resulta cómoda o si tienes todas las funcionalidades de tu hardware.

      En la particular del artículo, se refiere a la aceleración 3D de la ATI 4200, la cual tiene ciertos problemas con la version 12.10 Quantal (sin soporte a largo término, o sea, no LTS).

      Atte.

      Juan Perón

      Eliminar
  13. Queridos amigos y compañeros, espero no estar dando información repetida.

    Tengo Ubuntu 12.04.2 (point release de Precise Pangolin que incorpora paquetes de Quantal) y googleando hallé una forma de retrotraer el X.org Xserver de 1.13 a 1.12.4 sin necesidad de reinstalar el sistema.

    Las instrucciones están aquí y, al menos a mí, me funcionó:

    https://launchpad.net/~makson96/+archive/fglrx

    Desde que ejecuté esas instrucciones pude usar correctamente mi tarjeta Radeon con los controladores legacy de AMD/ATI, ya que antes me tenía que conformar
    con un VESA genérico y de 2D.

    ResponderEliminar
    Respuestas
    1. Estimado Linuxero:

      La resolución que figura la hemos puesto como solución, y efectivamente, funciona muy bien.

      sudo add-apt-repository ppa:makson96/fglrx
      sudo apt-get update
      sudo apt-get upgrade
      sudo apt-get install fglrx-legacy

      Agradecemos su aporte!

      Atte.

      Juan Perón

      Eliminar
  14. hola, está muy buena la pág. Necesito preguntarle algo acerca del paquete compilado en la opción 3. Cuando agrego el repositorio me aparece un montón de aclaraciones entre las que figura que no funciona para ubuntu 12.04.03 que es el que tengo instalado. Que puedo hacer??

    ResponderEliminar
  15. Hola, tengo un problema al instalar el driver ati hd4200, vera en el live cd me detecta los driver privativos pero una ves instalado la version 12.04 con conexion a internet y descargando actualizaciones, no me detecta ningun driver privativo, ahora intento insalarlo de las 3 maneras aqui posteadas y me manda error, en el paso 1 me manda este mensaje:
    One or more tools required for installation cannot be found of the system.
    Install the required tools before installing the fglrx driver. Optionaly, run the installer with --force option to install without the tools ...............
    See usr/share/ati/fglrx-install.log para mas informacion.

    ---------------------------------
    y esto es lo que arroja el fglrx-install.log:
    Check if system has the tools required for installation.
    fglrx installation requires that the system have kernel headers. /lib/modules/3.11.0-15-generic/build/include/linux/version.h cannot be found on this system.
    One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
    Optionally, run the installer with --force option to install without the tools.
    Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.
    ---------------------------
    No se que tengo que hacer... Ayudaa por favor

    ResponderEliminar
    Respuestas
    1. Estimado anónimo:

      Los verdaderos logros son los que otorga la lucha por el bienestar en el trabajo y la Libertad en el software.

      En este caso el sistema te instruye que careces de algunos paquetes escenciales para que se pueda compilar y aplicar el módulo del controlador en tu sistema. Normalmente esto se debe porque estás usando el Live CD en lugar de una instalación directa.

      En tu caso, simplemente requieres instalar el paquete build-essential, que contiene las herramientas básicas de compilación. También podría ser útil descargar los encabezados del kernel (linu-hjeaders).
      Para instalarlos debes abrir una terminal con Ctrl+Alt+T e ingresar los siguientes comandos:

      sudo apt-get update
      sudo apt-get install build-essential linux-headers-`uname -r`

      Luego reintenta la instalación del controlador AMD/ATI para tu ATI4200.

      Atte.

      Juan Perón

      Eliminar
  16. Hola, me e descargado la versión Ultimate Edition 3.4 que esta basada en la 12.04, lo instale porque quería ver si con esta versión podía instalarse sola el driver pero para mi mala fortuna no se instalo. en antiguas versiones de UE si se me instalaba sola.
    Probare por realizar lo que me sugieres y comento como me fue...

    ResponderEliminar
    Respuestas
    1. Estimado Anónimo:

      El tema no es tanto la instalación automática del controlador, sino que la última versión del mismo ya no contempla el chipset ATI3600/4200, los cuales han dejado de ser soportados con las últimas versiones de XOrg y del controlador nVidia, lamentablemente.

      Atte.

      Juan Perón

      Eliminar
  17. Estimado Juan Perón:
    Tengo una notebook Acer aspire 5552 con una Ati mobility Radeon HD 4250.
    Puedo instalarle Linux MInt 17 y usar alguno de estos métodos?. O instalar Ubuntu 14.04 y usar estos métodos?. O tengo que usar ubuntu 12.10 para que me funcione bien?.
    Como compruebo si está funcionando correctamente?.
    Desde ya muchas gracias por su tiempo y su paciencia.
    Atte.
    Tomás

    ResponderEliminar
    Respuestas
    1. Estimado Tomás:

      Le recomendamos utilizar Ubuntu 12..04LTS pues contará con algunos años más de soporte.
      También podrá emplear Ubuntu 14.04LTS más advertirá que no podrá cargar el controlador oficial AMD Mobility Radeon pues ha sido descontinuado para la línea 22xx, 32xx y 42xx de Ati/AMD. No obstante, contará con un controlador alternativo de funcionamiento adecuado.

      Para comprobar el funcionamiento correcto del video, querrá estar atento a ciertas imperfecciones de los controladores alterantivos libres, los cuales eran video "cortado" o poco fluido verticalmente, "entrecortamiento" de video al mover una ventana de video, y desempeño lento en general al aplicar efectos de video 3D (por ejemplo, tarda la pantalla al desenfocarse con los Lens de Ubuntu y demás).

      Estos problemas fueron suplidos o solucionados en buena medida con las diferentes actualizaciones y kernels que fueron saliento para 12.04LTS.

      Atte.

      Juan Perón.

      Eliminar