martes, 23 de diciembre de 2014

¿Cómo instalo Google Earth en Ubuntu 14.04LTS de 64 bits?

Como hombre de su tiempo, Juan Perón entendió que en ocasiones debería mirar al mundo para comprender el devenir político de la historia. Y para ello, enseñó cómo instalar Google Earth en Ubuntu 14.04 de 64 bits y superior.

Nota: Este artículo es válido para Ubuntu 14.04LTS Trusty Tahr. Para la versión actualizada para Ubuntu 16.04LTS Xenial Xerus, vea aquí.

(...) Si analizamos el panorama del mundo podremos ver perfectamente como el dominio de las masas populares - en las que los trabajadores constituyen el centro de gravedad - ha ido produciendo en los distrintos países, la desaparición de muchas instituciones pertenecientes a la época de la revolución francesa.
Miremos ahora el panorama de nuestro país. Los grandes partidos que antes concentraban cientos de miles de hombres, en los últimos tiempos apenas llegan a reunir cifras muy inferiores. Las masas de trabajadores saben perfectamente bien cual es la situación dentro del país, y no necesitan ir a buscar inspiración fuera de él.

Pero siempre es necesario tener un ojo puesto en el mundo, aunque sea para otra cosa. Una gran herramienta para ello es la que puede presentar Google Earth, la conocida aplicación para observación terrena.

Ya hace varios años que esta aplicación ptivativa se encuentra disponible para plataformas GNU con Linux. Sin embargo, existen problemas para instalar dicho paquete en los sistemas operativos de versión de 64 bitios, lo que podría ser negativo para el neófito.

Es sabido que los sistemas operativos tipo GNU existen en versiones de 32 bits y las cada vez más extendidas de 64 bits. Esta diferenciación, llamada "arquitectura", responde de  manera básica a cómo está estructurada la gestión de bloques de memoria del equipo en su microprocesador, y hace que el sistema operativo pueda funcionar de una manera más eficiente, con capacidad de manejar cantidades de datos más ingentes. Poco a poco, las arquitecturas de 64 bitios van reemplazando a las de 32, con las cuales son retrocompatibles.

Como Justicialistas, hemos de estar dispuestos no sólo a presentar una solución, sino también una cosmovisión que explique el porqué ha de darse tal situación y no otra.

Pues bien. Vean señores, con el objeto de compatibilizar las aplicaciones de 32 bits con las de 64 bits, durante cierto tiempo se utilizó el paquete ia32-libs, que contenía librerías múltiples de inter-ejecución. A partir de la versión 13.10 de Ubuntu, se dejó de utilizar ia32-libs para favorecer el soporte multiarquitectura (multiarch), capaz de operar tanto en 32 como en 64 bits sin distinción.


Sin embargo, algunos empaquetados de 64 bits (que son realmente aplicaciones de 32 bits) aún dependen de algunas librerías que venían contenidas en el paquete de librerías ia32-libs y por ello no pueden ser instalados tan fácilmente en Ubuntu 14.04LTS o 13.10 de 64 bits.

La aplicación Google Earth es un ejemplo de ellas, y será gorila. Si descargamos el paquete de 64 bits desde la web oficial y probamos instalarlo en un Ubuntu 13.10, 14.04LTS o superior, el Centro de Software nos informará que nos falta la dependencia ia32-libs y se negará a cargarlo.

La forma correcta de instalar un paquete que requiera ia32-libs, es directamente instalar el paquete oficial en su versión de 32 bits. Naturalmente, esto también instalará una serie de paquetes de 32 bits, pero tal es la manera en la cual ha de funcionar la Multiarquitectura.

Aún así, el paquete de 32 bits de Google Earth no soporta multiarquitectura. Por lo tanto, se debe instalar a mano sus dependencias. Para ello abrimos la consola Terminal, e ingresamos los siguientes Comandos de Organización:

sudo apt-get install libfontconfig1:i386 libx11-6:i386 libxrender1:i386 libxext6:i386 libgl1-mesa-glx:i386 libglu1-mesa:i386 libglib2.0-0:i386 libsm6:i386


Tengamos presentes que el :i386 de las librerías anteriores le indican al sistema que busque las versiones de 32 bits de cada uno.

Acto seguido, podremos continuar la instalación de Google Earth desde la Terminal. Lo haremos descargando el paquete de 32 bits e instalándolo, con los siguientes comandos de Organización:

cd ~/Descargas

wget http://dl.google.com/dl/earth/client/current/google-earth-stable_current_i386.deb

sudo dpkg -i google-earth-stable_current_i386.deb


Es probable que el sistema nos indique algún problema o error por falta de librerías o dependencias, pero se instalarán cuando le ordenemos corregir la falla, con el siguiente comando:

sudo apt-get install -f

Una vez concluido todo, podremos ejecutar el programa. Simplemente abrimos el Dash y buscamos la aplicación Google Earth, que estará en su versión más reciente.

4 comentarios:

  1. impresionante.... todo perfecto, a cuatro dias de la eleccion a presidente, un peronista ya me dio una alegria, gracias

    ResponderEliminar
  2. Hola, lo hice y aparece la pantalla del programa negra con puntos blancos cuadrados y el contorno del globo en amarillo. No se ve el mapa.
    Antes dio un aviso de resoluci[on de pantalla insuficiente. tengo una Note book dell inspiron mini 1018... si conoces la soluci[on te lo agradezco. Saludos

    ResponderEliminar
    Respuestas
    1. Estimado Anónimo: en ese caso se debe a que este programa requiere un controlador de video 3D, cosa que no trae la Mini 1018 lamentablemente (solo dispone de aceleración 2D).

      Atte.

      Juan Perón

      Eliminar